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Using This Document

Before You Begin
To install MassTransit 6.1 on Windows 2003 or Windows 2008 you will need to have a version 6 serial
number.

This serial number is provided with your MassTransit download package. Please contact Group Logic
Support at 703-527-7979 or support@grouplogic.com if you need to obtain the serial number.

Note that if you already have MassTransit installed, you should use the MassTransit 6.1 upgrading
document, not this document, which assumes you are doing a fresh MassTransit installation.

You should be logged in as an administrator to install MySQL and MassTransit 6.1.

System Requirements

For a complete listing of all system requirements, please see the MassTransit ReadMe. We strongly
recommend that you contact the Group Logic MassTransit team to consult with them prior to purchasing
or upgrading a system to run MassTransit. Using their expertise in this area, the team can evaluate with
you your specific needs and determine the optimal system configuration for use with MassTransit under
those conditions. Group Logic has discontinued support for Windows 2000.
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Install MySQL 5
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Prior to installing MassTransit, you will need to install MySQL 5.0.78; this is also provided in your
MassTransit 6.1 download package. MassTransit is dependent upon MySQL, so if it is not running, then
MassTransit cannot be installed. MassTransit 6.1 requires MySQL 5.0.

NOTE: If you have an earlier version of MySQL already installed, you must uninstall the old MySQL
service and then restart MySQL after you have successfully upgraded to MySQL 5.0.78 to complete the
installation. For additional information, go to http://dev.mysal.com/doc/refman/5.0/en/upgrade.html.

Installing MySQL

Follow the below instructions to install and launch MySQL.

1.

2.
3.
4,

10.
11.

12.

13.

14.

15.
16.

17.

Unzip the MySQL installation files, mysql-classic-5.0.78-win32.zip, located in your download
package. A directory opens containing the required installer, Setup.exe.

To install the MySQL engine, double click Setup.exe.

An introduction window appears. Select the Next button to proceed.

The OLicense AgreementO window appears. Thilext button is enabled after you select | accept
the terms in the license agreement . Read the license and select Next to continue or select
Cancel to cancel the installation.

The OSetup TypeO window appears. Select th&ypical setup type and then select the Next
button.

The OReady to Install the ProgramO window appears next. Once you have verified that all of the
settings are accurate, select the Install button.

While the installation completes, the Olnstalling MySQL Server 5.00 window appears.

Two OMySQL Enterprise SubscriptionO windows appear nexOn both windows you may select
More for more information or Next to continue.

The OWizard CompletedO window appears next. Check th€onfigure the MySQL Server now
check box to configure your server. Select the Finish button to proceed.

The OMySQL Server Instance Configuration WizardO then launches; selediext to continue.

The next window asks you to select a configuration type. Select the Standard Configuration and
then select Next to continue.

The next window asks you to set the Windows options:

a. Check the checkbox for Install As Windows Service

b. Select MySQL for the Service Name .

c. Check the checkbox for Launch the MySQL Server automatically

d. Check the checkbox for Include Bin Directory in Windows PATH

e. Select Next.

The next window asks you to set the Security options:

a. Select the Modify Security Settings checkbox to set a password for your root account.
You should use a strong root password of 8 or more characters with a variety of letters,
numbers, and symbols.

i. Enter the root password.
ii. Retype the password for verification.
iii. Select the Enable root access from remote machines  checkbox if you would
like to give remote machines root access to MySQL. This is not recommended.

b. Uncheck the Create An Anonymous Account checkbox.

c. Select Next to continue.

The OReady to executeEO window appears next. Select theExecute button to start the
configuration.
Once the configuration is complete select the Finish button.
Go to the folder where you installed MySQL (by default, C:\Program Files\MySQL\MySQL Server
5.0). Open the my.ini file in a text editor.
Add the following line to the end of the file:

temp- pool=0
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18. Save and close my.ini.
19. In the services control panel, restart the MySQL service.

Security Configurations for MySQL

It is critical that the directory where the MySQL database files are stored (c:\Program Files\MySQL Server
5.0\data by default) and the Windows temp directory (c:\tmp) be excluded from virus scan and server
backups. Both virus scan tools and backup tools can lock key files in these folders and interrupt operation
of the MySQL server, and by extension, MassTransit.

To backup the MySQL databases, it is recommended that you use the MySQL or other standard tools to
automatically save the backup files to a directory or volume that can then be processed by your backup or
archiving solution.

By default, MySQL uses TCP/IP port 3306 to accept client communications. It is recommended to restrict
traffic on this port by setting appropriate firewall rules. Normally, the only remote computers that should
be allowed to access MySQL on the MassTransit server are those running the MassTransit Administrator
(or those running the MassTransit Engine or MTWeb in the rare configurations where MySQL is not
running on the same server as MassTransit).

Installing MySQL GUI Tools

Below are instructions for installing the MySQL GUI tools. Two of the most commonly used tools for
administering and troubleshooting the MassTransit server are the MySQL Administrator and the MySQL
Query Browser.

If you are upgrading from MySQL 4 to MySQL 5, you will need to install the updated versions of the
MySQL Administrator and MySQL Query Browser. The tools are available in the mysql-gui-tools-com-5.0-
r12-win32.zip in the MySQL folder of your MassTransit download package.

To install the MySQL GUI Tools

1. Double-click mysql-gui-tools-com-5.0-r12-win32.msi.

2. Anintroduction window appears. Select the Next button to proceed.

3. The OLicense AgreementO window appears. ThBlext button is enabled after you select | accept
the terms in the license agreement . Read the license and select Next to continue or select
Cancel to cancel the installation.

4. The ODestination FolderO window appears. Select th€hange button to install to a different
location; select Next to continue.

5. The OSetup TypeO window appears. Select th€omplete setup type and then select the Next
button.

6. The OReady to Instdl the ProgramO window appears next. Once you have verified that all of the
settings are accurate, select the Install button.

7. Two OMySQL Enterprise SubscriptionO windows appear nexOn both windows you may select
More for more information or Next to continue.

8. The OWizard CompletedO window appears when the installation is complete. Select thEinish
button to exit.
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Install MassTransit

Running the MassTransit Installer

1. Verify MySQL 5.0.78 is running as a service. Go to the Services window to verify via Start ->
Programs -> Administrative Tools -> Services.

NOTE: If MassTransit is running on a remote server, separate from where MySQL is installed you
will need to execute the following command on the MySQL command prompt before installing
MassTransit :

GRANT ALL PRIVILEGES ON *.* TO 'root'@'<REMOTE IP ADDRESS>' identified
by '<PASSWORD>' WITH GRANT OPTION

In the above statement, replace <REMOTE IP ADDRESS> with the MassTransit Server IP
Address and replace '<PASSWORD>' with the root MySQL password.

2. Double click InstallMT6Server.exe to launch the InstallShield Wizard. Note: you may quit the
installation at any time; the Cancel button is enabled until the Install button is selected.

3. A OPreparing to InstallEO window remains open until the installation prepeation is complete.

4. When the installation preparation completes, the OWelcome to the InstallShield Wizardfor
MassTransit Server 60 window appears. Select theNext button to continue.

5. The OLicense AgreementO window appears next. ThBlext button is enabled after you select |
accept the terms in the license agreement . Once you have read and agreed with the license
agreement, select Next to continue or select Cancel to cancel the installation.

6. The OReadMe InformationO window appears next; read it and seledtiext to continue.

7. The OMassTransit Server 6FeaturesO window appears next. Select the features that you would
like to install.

{& MassTransit Server 6 - InstallShield Wizard x|

MassTransit Server 6 Features
Select the program features you want installed.

Mote: Installing the Engine will automatically install the Administrator as well.

[V MassTransit Administrator

[V MassTransit Manuals

InstaliShield

< Back l Mext > I Cancel

a. Allitems are checked by default.

b. Checking the MassTransit Server Engine option will install both the Engine and the
MassTransit Administrator; this is necessary so you can configure the Engine.

c. Checking just the MassTransit Administrator option will install just the Administrator.
MassTransit Premier and Standard allow local and remote Administrators to connect if
remote administration is enabled for both MySQL and the MassTransit Engine Additional
details can be found below in the Configuring Remote Administration section.

d. Checking the MassTransit Manuals option will install manuals and documentation.

e. Once you have made your selection, select Next to continue.

8. The OMySQLSettingsO window appears next.
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{i MassTransit Server 6 - InstallShield Wizard B x|
MySQL Settings !‘,.

This step will create or modify the MassTransit database user account.

MassTransit Installation Guide for Windows

~MySQL MassTransit Account

Hostname:
Port:

Username:
Password:

Confirm Password: [

[V Enable remote login for this account

MySQL Root Password: frcssorscrsontons|

localhost
3306
masstransit

I Next > I Cancel |

< Back

a. In the MySQL MassTransit Account section, the following information is required:

VI.

Hostname: [default: localhost] Leave this setting configured as OlocalhostO so
MassTransit can access the local database. Do not use your local IP address. If
MassTransit is on a remote server, enter the IP address of the machine where
MySQL is installed.

Port: [default: 3306] Leave this setting configured to 033060 unless you have
changed the TCP port used by the MySQL database server (this is rare).
Username: [default: masstransit] This will be the name of the user account
created in MySQL that MassTransit will use to access the database. You may
change it to any username you wish. Do not use root.

Password: This will be the password for the user account created in MySQL that
MassTransit will use to access the database. You may change it to any password
you wish.

Confirm Password: Please retype your password for verification.

OEnable remote login for this accountO: [default: not selected)] If you wish to allow
administration of the MassTransit server using the MassTransit Administrator
from other machines, you will need to check this option. If it is not checked, your
MassTransit server will not allow remote administration, although you will be able
to administer the server locally. If you wish to allow remote administration, it is
recommended that you enable it at this time; if you do not enable it now, you will
later have to manually configure the proper permissions for both MassTransit and
MySQL. Instructions on how to manually configure this can be found below in the
Configuring Remote Administration section of this document.

b. Enter your MySQL root password. The root password is required so that the MassTransit
installer can create the new user account in MySQL.
c. Select Next to continue.
9. Once the installer validates the entered information, a dialog appears stating, OMySQL account
configured successfully!O SelectOK to continue.
10. The ODestination FolderO window appears. The default installation location is @®rogram
Files\Group Logic\MassTransit Server 6\.
a. Selectthe Change button to install to a different location.
b. Select Next to continue.
11. The OCustomer InformationO window appears next; all fields are mandatory.
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12.

13.

14.

15.

16.

17.

18.

MassTransit Installation Guide for Windows

i MassTransit Server 6 - InstallShield Wizard ! x|
Customer Information z &
Please enter your information. -

User Name:

[Administrator

Organization:

[GroupLogic

Serial Number:

Server Mame:
JHousTON

Install this application for:
& anyone who uses this computer (all users)

" Only for me (Administrator)

< Back ] Cancel

Enter your User Name.

Enter the name of your Organization .

Enter the Serial Number provided to you by Group Logic.

Enter the Server Name ; it auto-populates so verify that it is correct.

Select whom the application should be installed for: anyone using this computer or only
you. The default is Anyone who uses this computer (all users)

f. Select Next to continue.

The OReady to Instdlthe ProgramO window appears next. If you would like to make any changes
to your installation, do so now. Once you have verified that all of the settings are accurate, select
the Install button.

A dialog will appear asking, OWould you like to install Dogle Drivers?0 Selectyes.

A dialog appears stating that the dongle must be removed prior to the installation. If you have a
MassTransit hardware dongle plugged in, remove it now. Once the dongle has been unplugged
select OK to continue. You will be prompted later to plug the dongle back in.

A dialog appears stating that the Sentinel Protection installer is being configured. This installs the
drivers for the dongle.

Once the Sentinel Protection Installer is complete, a dialog will prompt you to plug the dongle in.
If you have one, plug it in and select OK to continue. Otherwise, just click OK.

When the installation is complete, the OlnstallShield Wizard CompletedO window appears. Select
Finish .

If you have a mtdongle.cfg file that you received from Group Logic, copy it into the MassTransit
installation directory. This file contains your license information.

©To0T R

Troubleshooting

Problem: 1 did not get a dialog stating OMySQL account configured successfully!O while installing
MassTransit.
Solution:

1.

2.
3.
4,

Is the MySQL service running? Go to the Services window to check via Start -> Programs ->
Administrative Tools -> Services.

Did you enter the correct MySQL password?

Did you incorrectly leave the MySQL Root password field blank?

If MySQL is on a separate server, did you follow the directions for remote server install in step 1?

Launching the MassTransit Engine

1.

The MassTransit Engine must be started via the Services window. To access the Services

window, go to Start -> Programs -> Administrative Tools -> Services.
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2. Once the Services window is open, highlight the service named OMassTransitO and select the
Start Service button.

3. The default startup type for the MassTransit service is Automatic, thus anytime your machine
reboots, the MassTransit service automatically starts.

NOTE: MassTransit is dependent upon MySQL 5 and will fail if MySQL is not started. Make sure
MySQL is set to start automatically. If you find that MassTransit is attempting to start before
MySQL is ready, you can modify the options in the Recovery tab of the MassTransit service to
have it retry.

4. If you would like the MassTransit Engine service to access network volumes, do the following:
a. Go to the Services window via Start -> Programs -> Administrative Tools ->
Services. Highlight the MassTransit service, right click, and select Properties to open
the "Properties" window.
b. Go to the Log On tab and select the This account: option.
i. Select the Browse E button to browse for your valid domain user that has
access to the volumes needed.
ii. Enter and confirm your password.
iii. Select OK to finish and close the "Properties" window.

Shutting Down the MassTransit Engine

To shut down the MassTransit Engine, open the Services window, select the MassTransit service, and
select the Stop Service button.

Launching the Mass Transit Administrator

1. Double click the MassTransit Administrator.exe located in the root MassTransit folder to connect
to your MassTransit server; the default location is C:\Program Files\Group Logic\MassTransit
Server 6.

2. The OMassTransit ServersO windowppears.

r
MassTransit Servers

Select a MassTransit server from the list and click Connect to establish a
% connection and view the server's status and configuration.

<

Server

< >

Edit Server List...

3. Add the server you wish to connect to: . )
a. Select the Edit Server ListE  button; the OMassTransit Server ListO appears.
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r
MassTransit Server List

% Server Address Port

<] >

b. Select the Add button; the OConfigure MassTransit Server ConnectionO dialog appears.

Configure MassTransit Server Connection

Enter a name to identify this MassTransit server along with its internet
address and port number. The default port number is 20002,

Name

Address

Port 20002

Cancel

c. Add the name and address of the server you are connecting to; all fields are required. If
Remote Administration is enabled and you are connecting to a remote server, enter that
machineOs information; see theRemote Administration section of this document for
additional information.

i. Enter the server Name (or localhost if you are connecting locally); this is just a
name to identify the server youOre connecting to.
ii. Enter the server IP Address (or localhost if you are connecting locally).
iii. Enter the Port. Use 20002 (the default) unless the MassTransit server has been
configured to use a different port.

d. Select OK to continue.

4. After selecting OK you return to the OMassTransit Server ListO window and see the server you just
created.
5. To connect, highlight the server entry and select Connect .

NOTE: You will be able to connect to the server only when the Engine is running, otherwise a
dialog will appear stating that a connection cannot be made to the server.

6. The OMassTransitO window appears with a tibar of the following buttons: Contacts , Status,
Files, Log, and Setup. Click any button to go to the corresponding window.

HINT: If you always want the MassTransit Administrator to connect to the same server, go to Edit Server
ListE and highlight that server in the list. Then click the Make Default button and click Close . Now when
you launch the MassTransit Administrator, it will automatically connect to the default server.

Shutting Down the MassTransit Administrator

To disconnect from the server only, go to the File menu and select Disconnect From Server . To exit the
MassTransit Administrator, go the File menu and select Exit.
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Troubleshooting

Problem: The MassTransit Engine shut down immediately upon launch.

Solution: Look for an error log entry on the Application page of the Event Viewer. To open the Event
Viewer, go to Start -> Programs -> Administrative Tools -> Event Viewer. Look for an Error type and the
source name should have OMassTransitO in it. Select the error and double click it. Whethe event opens,
look at the description; the last few sentences of the description are frequently the most informative. Make
sure you have MySQL 5 installed. MassTransit 6.1 will not run if MySQL 4 is installed. Verify from the
Services window that MySQL is running.

Problem: The MassTransit Administrator shut down immediately upon launch.
Solution:
1. Verify the Engine is running. When the Engine is not running a dialog appears stating, OAn error
occurred with MassTransit: Unable to connect to the MassTransit server.O
2. Look for an error log entry on the Application page of the Event Viewer. To open the Event
Viewer, go to Start -> Programs -> Administrative Tools -> Event Viewer. Look for an Error type
and the source name should have OMassTransitO in it. Set the error and double click it. When
the event opens, look at the description; the last few sentences of the description are frequently
the most informative.
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Configuring Remote Administration  of MassTransit

The file transfer engine runs as a service and can be accessed for viewing and administration by a
separate application, the MassTransit Administrator. MassTransit Premier and Standard allow local and
remote Administrators to connect if remote administration is enabled for both MySQL and the
MassTransit Engine.

The easiest way to configure remote administration for MySQL is to check the checkbox when you install
MassTransit 6.1. If you already have MassTransit installed and want to enable Remote Administration,
use the following instructions. Both MassTransit and MySQL will need to be configured before remote
connections will be accepted.

Configuring Remote Administration in MassTransit

1. Viathe MassTransit Administrator connect to the local server.
2. Select the Setup button on the toolbar.
3. Select the Special tab.

Incaming Calls || Dutaoing Calls | Serices | Actions ~Special IPriovitjes] Secuity |

~ Log and File Handling

™ Clear log entries older than days ™ Clear file entries older than |5 days

—Server-to-Server Ci
€ Decline calls from unknown MassTransit Servers

@ Accept calls from unknown MassTransit Servers ™ Require Password: I

— &dmini; Setting:

Set Remote Administrator Password

 Location of MassTransit Web Page:

Path: Choose... I

 Location of User Mailb Folder

C:\Program Files\Group LogictMassTransit Server 5
& Use Default Location
€ Use Custom Location CHoose),.

10, Cancel I

4. Click the Set Remote Administrator PasswordE button.

5. The Enter Password dialog appears; enter your password. This password will have to be entered
by a Remote Administrator when it attempts to connect to your server.

6. Select the OK button and now any Remote Administrators with the password can connect to your
server.

Configuring Remote Administration in MySQL

NOTE: This is unnecessary if you selected the Enable remote login for this account  checkbox during
installation.

1. Launch the MySQL Administrator.
2. Select the User Administration page.
a. Under User Accounts select the OmasstransitO account. This account may have a different
name depending on the username you entered on the OMySQL SettingsO dialog during
the installation of MassTransit.
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& MySQL Administrator - root@Iocalhost:3306 - [Ofx]
File Edt View Tools Help

2
4f Seeenfrmaton User Information | Scheme Privleges | Resources |

(3 sewice Contrl i
S (o) masstransit
13 statup Varcbles ~ | et e e o
|38 User dmiistration -
_{‘ Server Connections .
MySaL User: masstiansit The user has to enter this MySQL User name to connect to
Ui Healh the MySOL Server
19 serverLogs Password: Fill ot tis feld it you want to set the user's password
j Replication Status X . X
Confiim Password: [ Again, enter the user's password to confim

¢
o Backup

-
< Restore (~Addiional Information

J Catalogs
(=7 9 Full Name: [ Theusershulname
Users Accounts | Description: Addiional description of the user
o Email: The user's email address
3 mml Contact Information: Optional contact information
Icon: =) Load from Disk_ | loon assigned to the user
“ Clearimage

4

b. While focus is on OmasstransitO right click and selecAQd host from which the user can
connectO.

c. The OAdd HostO dialog appears; entehe name of the new host, and select OK to
continue. Using O%®@ill allow any machine to connect to the database. For security
purposes, it is better to specify a specific host IP if only a limited number of hosts will
need to perform remote administration.

Add Host ' X|

| } Enter a new Host the User can connect from.

Host [%

ok | abor |

d. The new host populates below the masstransit account.

e. The password on the General tab auto-populates the MySQLpassword used when you
installed MassTransit. Remote administrators will not need to know this password to
connect.

NOTE: Do NOT select the Apply Changes button until this host is completely
configured.

3. Verify the host you just created in the Users Accounts section is highlighted and select the
Schema Privileges Tab.
a. Inthe Schemas section, highlight mtdatabase.
b. Go to the Available Privileges Section and highlight all of the items listed.
c. Click the < button so all of the Available Privileges become Assigned Privileges.
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UserIrformation - Schema Privieges | Resources |

a masstransit
4 5chema Piiviledges assigned to the User

Schemata Available Privileges

- 3 I
] G CREATE_TM >
B [ Server Logs mysal B orLere
) Replcation Status test 3 «
¢
@ Backup R
2 Restore ; —,
[/ Catelogs FLLOCK_TABLES
7 REFERENCES
T SELECT
Users Accounts | FLUPDATE
o
& masstransit
%
3 root

New User | Apply changes | Discard changes |

4
NOTE: Do NOT select the Apply Changes button until this host is completely
configured.

4. Go to the Resources tab.
a. Configure the values in the Limiting user resources section. The default is ©00; OUnlimitedO
is the default when the MassTransit installer creates this account.
b. Selectthe Apply Changes button.

NOTE: When you select the Apply Changes button, it looks like the host you just
created has disappeared. It has not disappeared,; it is just no longer visible from the
MySQL Administrator.

Now that you have configured both MySQL and MassTransit, Remote Administration is enabled.

Troubleshooting

Problem: A dialog appears stating, OAn error occurred with MassTransit: Remote Administration is
disabled because the required password has not been configured.O
Solution: Remote Administration is not enabled in MassTransit; follow Steps 1-6 to configure it.

Problem: A dialog appears stating, OAn error occurred with MassTransit: Failed to connect to server due

to problems initializing ® most likely a database issue.O
Solution: Remote Administration is not enabled in MySQL; follow Steps 1-4 to configure it.
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Web Configuration for Standard and Premier Servers

For information about configuring MassTransit for use with web servers, see the Web Configuration
Instructions document located on the MassTransit Latest Releases web page in the MassTransit 6.1
Documentation section: http://www.grouplogic.com/files/glidownload/mtreleases.cfm.

Other MassTransit 6. 1 Resources
Go to http://www.grouplogic.com/files/mt/61/OtherMassTransit6 1Resources.html for additional articles to

help you set up, configure, and use MassTransit 6.1 and its new features. The Group Logic Knowledge
Base contains many articles that provide detailed information on MassTransit 6.1 and its features and
components.

Group Logic M assTransit Technical Support

Please contact Group Logic Technical Support if you need assistance with installing MassTransit. Email
support@grouplogic.com or call 703-527-7979. For a complete listing of the latest official release versions
and documentation, go to http://www.grouplogic.com/files/glidownload/mtreleases.cfm.
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