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Using This Document 
 
 

Before You Begin 
To install MassTransit 6.1.1 on Windows 2003 or Windows 2008 you will need to have a version 6 serial 
number.  
 
This serial number is provided with your MassTransit download package. Please contact Group Logic 
Support at 703-527-7979 or support@grouplogic.com if you need to obtain the serial number. 
 
Note that if you already have MassTransit installed, you should use the MassTransit 6.1.1 upgrading 
document, not this document, which assumes you are doing a fresh MassTransit installation. 
 
You should be logged in as an administrator to install MySQL and MassTransit 6.1.1. 
 
 

System Requirements 
For a complete listing of all system requirements, please see the MassTransit ReadMe. We strongly 
recommend that you contact the Group Logic MassTransit team to consult with them prior to purchasing 
or upgrading a system to run MassTransit. Using their expertise in this area, the team can evaluate with 
you your specific needs and determine the optimal system configuration for use with MassTransit under 
those conditions. Group Logic has discontinued support for Windows 2000. 
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Install MySQL 5 
Prior to installing MassTransit, you will need to install MySQL 5.0.78; this is also provided in your 
MassTransit 6.1.1 download package. MassTransit is dependent upon MySQL, so if it is not running, then 
MassTransit cannot be installed. MassTransit 6.1.1 requires MySQL 5.0. 
 
NOTE: If you have an earlier version of MySQL already installed, you must uninstall the old MySQL 
service and then restart MySQL after you have successfully upgraded to MySQL 5.0.78 to complete the 
installation. For additional information, go to http://dev.mysql.com/doc/refman/5.0/en/upgrade.html. 
 
 

Installing MySQL 
Follow the below instructions to install and launch MySQL. 

1. Unzip the MySQL installation files, mysql-classic-5.0.78-win32.zip, located in your download 
package. A directory opens containing the required installer, Setup.exe.  

2. To install the MySQL engine, double click Setup.exe. 
3. An introduction window appears. Select the Next button to proceed. 
4. The “License Agreement” window appears. The Next button is enabled after you select I accept 

the terms in the license agreement. Read the license and select Next to continue or select 
Cancel to cancel the installation. 

5. The “Setup Type” window appears. Select the Typical setup type and then select the Next 
button. 

6. The “Ready to Install the Program” window appears next. Once you have verified that all of the 
settings are accurate, select the Install button. 

7. While the installation completes, the “Installing MySQL Server 5.0” window appears.  
8. Two “MySQL Enterprise Subscription” windows appear next. On both windows you may select 

More for more information or Next to continue. 
9. The “Wizard Completed” window appears next. Check the Configure the MySQL Server now 

check box to configure your server. Select the Finish button to proceed. 
10. The “MySQL Server Instance Configuration Wizard” then launches; select Next to continue. 
11. The next window asks you to select a configuration type. Select the Standard Configuration and 

then select Next to continue. 
12. The next window asks you to set the Windows options: 

a. Check the checkbox for Install As Windows Service. 
b. Select MySQL for the Service Name. 
c. Check the checkbox for Launch the MySQL Server automatically. 
d. Check the checkbox for Include Bin Directory in Windows PATH. 
e. Select Next. 

13. The next window asks you to set the Security options:  
a. Select the Modify Security Settings checkbox to set a password for your root account. 

You should use a strong root password of 8 or more characters with a variety of letters, 
numbers, and symbols. 

i. Enter the root password. 
ii. Retype the password for verification. 
iii. Select the Enable root access from remote machines checkbox if you would 

like to give remote machines root access to MySQL. This is not recommended. 
b. Uncheck the Create An Anonymous Account checkbox. 
c. Select Next to continue. 

14. The “Ready to execute…” window appears next. Select the Execute button to start the 
configuration. 

15. Once the configuration is complete select the Finish button. 
16. Go to the folder where you installed MySQL (by default, C:\Program Files\MySQL\MySQL Server 

5.0). Open the my.ini file in a text editor. 
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NOTE: On 64-bit machines, the default location of MySQL is C:\Program Files 
(x86)\MySQL\MySQL Server 5.0. 
 

17. Add the following line to the end of the file:  
temp-pool=0 

 
18. Save and close my.ini. 
19. In the services control panel, restart the MySQL service. 

 

Security Configurations for MySQL  
It is critical that the directory where the MySQL database files are stored (c:\Program 
Files\MySQL\MySQL Server 5.0\data by default) and the Windows temp directory (c:\tmp) be excluded 
from virus scan and server backups. Both virus scan tools and backup tools can lock key files in these 
folders and interrupt operation of the MySQL server, and by extension, MassTransit.  
 
NOTE: On 64-bit machines, the default location of MySQL is C:\Program Files (x86)\MySQL\MySQL 
Server 5.0. 
 
To backup the MySQL databases, it is recommended that you use the MySQL or other standard tools to 
automatically save the backup files to a directory or volume that can then be processed by your backup or 
archiving solution.  
 
By default, MySQL uses TCP/IP port 3306 to accept client communications. It is recommended to restrict 
traffic on this port by setting appropriate firewall rules. Normally, the only remote computers that should 
be allowed to access MySQL on the MassTransit server are those running the MassTransit Administrator 
(or those running the MassTransit Engine or MTWeb in the rare configurations where MySQL is not 
running on the same server as MassTransit).  
 
 

Installing MySQL GUI Tools 
Below are instructions for installing the MySQL GUI tools. Two of the most commonly used tools for 
administering and troubleshooting the MassTransit server are the MySQL Administrator and the MySQL 
Query Browser. 
 
If you are upgrading from MySQL 4 to MySQL 5, you will need to install the updated versions of the 
MySQL Administrator and MySQL Query Browser. The tools are available in the mysql-gui-tools-com-5.0-
r12-win32.zip in the MySQL folder of your MassTransit download package. 
 
To install the MySQL GUI Tools 

1. Double-click mysql-gui-tools-com-5.0-r12-win32.msi. 
2. An introduction window appears. Select the Next button to proceed. 
3. The “License Agreement” window appears. The Next button is enabled after you select I accept 

the terms in the license agreement. Read the license and select Next to continue or select 
Cancel to cancel the installation. 

4. The “Destination Folder” window appears. Select the Change button to install to a different 
location; select Next to continue. 

5. The “Setup Type” window appears. Select the Complete setup type and then select the Next 
button. 

6. The “Ready to Install the Program” window appears next. Once you have verified that all of the 
settings are accurate, select the Install button. 

7. Two “MySQL Enterprise Subscription” windows appear next. On both windows you may select 
More for more information or Next to continue. 

8. The “Wizard Completed” window appears when the installation is complete. Select the Finish 
button to exit. 
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Install MassTransit 
 

Running the MassTransit Installer 
1. Verify MySQL 5.0.78 is running as a service. Go to the Services window to verify via Start -> 

Programs -> Administrative Tools -> Services. 
 
NOTE: If MassTransit is running on a remote server, separate from where MySQL is installed you 
will need to execute the following command on the MySQL command prompt before installing 
MassTransit : 
 
GRANT ALL PRIVILEGES ON *.* TO 'root'@'<REMOTE IP ADDRESS>' identified 
by '<PASSWORD>' WITH GRANT OPTION 

 
In the above statement, replace <REMOTE IP ADDRESS> with the MassTransit Server IP 
Address and replace '<PASSWORD>' with the root MySQL password. 

 
2. Double click InstallMT6Server.exe to launch the InstallShield Wizard.  

 
NOTE: you may quit the installation at any time; the Cancel button is enabled until the Install 
button is selected. 
 

3. A “Preparing to Install…” window remains open until the installation preparation is complete. 
4. When the installation preparation completes, the “Welcome to the InstallShield Wizard for 

MassTransit Server 6” window appears. Select the Next button to continue.  
5. The “License Agreement” window appears next. The Next button is enabled after you select I 

accept the terms in the license agreement. Once you have read and agreed with the license 
agreement, select Next to continue or select Cancel to cancel the installation. 

6. The “ReadMe Information” window appears next; read it and select Next to continue. 
7. The “MassTransit Server 6 Features” window appears next. Select the features that you would 

like to install. 
 

 
 

a. All items are checked by default. 
b. Checking the MassTransit Server Engine option will install both the Engine and the 

MassTransit Administrator; this is necessary so you can configure the Engine. 
c. Checking just the MassTransit Administrator option will install just the Administrator. 

MassTransit Premier and Standard allow local and remote Administrators to connect if 
remote administration is enabled for both MySQL and the MassTransit Engine Additional 
details can be found below in the Configuring Remote Administration section. 

d. Checking the MassTransit Manuals option will install manuals and documentation. 
e. Once you have made your selection, select Next to continue. 
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8. The “MySQL Settings” window appears next. 
 

 
a. In the MySQL MassTransit Account section, the following information is required: 

i. Hostname: [default: localhost] Leave this setting configured as “localhost” so 
MassTransit can access the local database. Do not use your local IP address. If 
MassTransit is on a remote server, enter the IP address of the machine where 
MySQL is installed. 

ii. Port: [default: 3306] Leave this setting configured to “3306” unless you have 
changed the TCP port used by the MySQL database server (this is rare). 

iii. Username: [default: masstransit] This will be the name of the user account 
created in MySQL that MassTransit will use to access the database. You may 
change it to any username you wish. Do not use root. 

iv. Password: This will be the password for the user account created in MySQL that 
MassTransit will use to access the database. You may change it to any password 
you wish.  

v. Confirm Password: Please retype your password for verification. 
vi. “Enable remote login for this account”: [default: not selected] If you wish to allow 

administration of the MassTransit server using the MassTransit Administrator 
from other machines, you will need to check this option. If it is not checked, your 
MassTransit server will not allow remote administration, although you will be able 
to administer the server locally. If you wish to allow remote administration, it is 
recommended that you enable it at this time; if you do not enable it now, you will 
later have to manually configure the proper permissions for both MassTransit and 
MySQL. Instructions on how to manually configure this can be found below in the 
Configuring Remote Administration section of this document.  

b. Enter your MySQL root password. The root password is required so that the MassTransit 
installer can create the new user account in MySQL. 

c. Select Next to continue. 
9. Once the installer validates the entered information, a dialog appears stating, “MySQL account 

configured successfully!” Select OK to continue.  
10. The “Destination Folder” window appears. The default installation location for 32-bit machines is 

C:\Program Files\Group Logic\MassTransit Server 6\ and C:\Program Files (x86)\Group 
Logic\MassTransit Server 6\ for 64-bit machines. 

a. Select the Change button to install to a different location. 
b. Select Next to continue. 

11. The “Customer Information” window appears next; all fields are mandatory. 
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a. Enter your User Name. 
b. Enter the name of your Organization. 
c. Enter the Serial Number provided to you by Group Logic. 
d. Enter the Server Name; it auto-populates so verify that it is correct. 
e. Select whom the application should be installed for: anyone using this computer or only 

you. The default is Anyone who uses this computer (all users). 
f. Select Next to continue. 

12. The “Ready to Install the Program” window appears next. If you would like to make any changes 
to your installation, do so now. Once you have verified that all of the settings are accurate, select 
the Install button.  

13. A dialog will appear asking, “Would you like to install Dongle Drivers?” Select Yes. 
14. A dialog appears stating that the dongle must be removed prior to the installation. If you have a 

MassTransit hardware dongle plugged in, remove it now. Once the dongle has been unplugged 
select OK to continue. You will be prompted later to plug the dongle back in. 

15. A dialog appears stating that the Sentinel Protection installer is being configured. This installs the 
drivers for the dongle. 

16. Once the Sentinel Protection Installer is complete, a dialog will prompt you to plug the dongle in. 
If you have one, plug it in and select OK to continue. Otherwise, just click OK. 

17. When the installation is complete, the “InstallShield Wizard Completed” window appears. Select 
Finish. 

18. If you have an mtdongle.cfg file that you received from Group Logic, copy it into the MassTransit 
installation directory. This file contains your license information. 
 
If you are installing MassTransit on Windows Server 2008 or Windows Server 2008 R2, you 
now need to follow the next steps for adding a Windows Firewall exception. Otherwise, 
skip to the next section.  
 

19. Open the Control Panel and click on the Windows Firewall option. 
20. In the window that appears, click on the “Allow a program through Windows Firewall” link (“Allow 

a program or feature through Windows Firewall” on Windows 2008 R2). 
21. Click on the “Add program…” button (“Allow another program…” on Windows 2008 R2). 
22. Browse the “MassTransit Engine.exe” in the MassTransit installation folder and select it. Click 

OK to confirm. 
23. On Windows Server 2008 R2, you can choose the networks the Firewall exception will be valid 

for (Domain, Private, or Public networks). Enable the exception only for the networks you want to 
use MassTransit on. 
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Troubleshooting 
Problem: I did not get a dialog stating “MySQL account configured successfully!” while installing 
MassTransit. 
Solution: 

1. Is the MySQL service running? Go to the Services window to check via Start -> Programs -> 
Administrative Tools -> Services. 

2. Did you enter the correct MySQL password? 
3. Did you incorrectly leave the MySQL Root password field blank?  
4. If MySQL is on a separate server, did you follow the directions for remote server install in step 1? 

 
 

Launching the MassTransit Engine 
1. The MassTransit Engine must be started via the Services window. To access the Services 

window, go to Start -> Programs -> Administrative Tools -> Services. 
2. Once the Services window is open, highlight the service named “MassTransit” and select the 

Start Service button. 
3. The default startup type for the MassTransit service is Automatic, thus anytime your machine 

reboots, the MassTransit service automatically starts. 
 
NOTE: MassTransit is dependent upon MySQL 5 and will fail if MySQL is not started. Make sure 
MySQL is set to start automatically. If you find that MassTransit is attempting to start before 
MySQL is ready, you can modify the options in the Recovery tab of the MassTransit service to 
have it retry. 
 

4. If you would like the MassTransit Engine service to access network volumes, do the following: 
a. Go to the Services window via Start -> Programs -> Administrative Tools -> 

Services.  Highlight the MassTransit service, right click, and select Properties to open 
the "Properties" window. 

b. Go to the Log On tab and select the This account: option. 
i. Select the Browse… button to browse for your valid domain user that has 

access to the volumes needed. 
ii. Enter and confirm your password. 
iii. Select OK to finish and close the "Properties" window. 

 
 

Shutting Down the MassTransit Engine 
To shut down the MassTransit Engine, open the Services window, select the MassTransit service, and 
select the Stop Service button. 
 
 

Launching the MassTransit Administrator 
1. Double click the MassTransit Administrator.exe located in the root MassTransit folder to connect 

to your MassTransit server; the default location for 32-bit computers is C:\Program Files\Group 
Logic\MassTransit Server 6 and C:\Program Files (x86)\Group Logic\MassTransit Server 6 for 64-
bit computers. 

2. The “MassTransit Servers” window appears. 
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3. Add the server you wish to connect to: 

a. Select the Edit Server List… button; the “MassTransit Server List” appears. 

 
b. Select the Add button; the “Configure MassTransit Server Connection” dialog appears. 

 
c. Add the name and address of the server you are connecting to; all fields are required. If 

Remote Administration is enabled and you are connecting to a remote server, enter that 
machine’s information; see the Remote Administration section of this document for 
additional information. 

i. Enter the server Name (or localhost if you are connecting locally); this is just a 
name to identify the server you’re connecting to. 

ii. Enter the server IP Address (or localhost if you are connecting locally). 
iii. Enter the Port. Use 20002 (the default) unless the MassTransit server has been 

configured to use a different port.  
d. Select OK to continue. 

4. After selecting OK you return to the “MassTransit Server List” window and see the server you just 
created. 

5. To connect, highlight the server entry and select Connect. 
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NOTE: You will be able to connect to the server only when the Engine is running; otherwise, a 
dialog will appear stating that a connection cannot be made to the server. 
 

6. The “MassTransit” window appears with a toolbar of the following buttons: Contacts, Status, 
Files, Log, and Setup. Click any button to go to the corresponding window. 

 
HINT: If you always want the MassTransit Administrator to connect to the same server, go to Edit Server 
List… and highlight that server in the list. Then click the Make Default button and click Close. Now when 
you launch the MassTransit Administrator, it will automatically connect to the default server.  
 
 

Shutting Down the MassTransit Administrator 
To disconnect from the server only, go to the File menu and select Disconnect From Server. To exit the 
MassTransit Administrator, go the File menu and select Exit. 
 
 
 

Troubleshooting 
Problem: The MassTransit Engine shut down immediately upon launch. 
Solution: Look for an error log entry on the Application page of the Event Viewer. To open the Event 
Viewer, go to Start -> Programs -> Administrative Tools -> Event Viewer. Look for an Error type and the 
source name should have “MassTransit” in it. Select the error and double click it. When the event opens, 
look at the description; the last few sentences of the description are frequently the most informative. Make 
sure you have MySQL 5 installed. MassTransit 6.1.1 will not run if MySQL 4 is installed. Verify from the 
Services window that MySQL is running. 
 
Problem: The MassTransit Administrator shut down immediately upon launch. 
Solution: 

1. Verify the Engine is running. When the Engine is not running a dialog appears stating, “An error 
occurred with MassTransit: Unable to connect to the MassTransit server.” 

2. Look for an error log entry on the Application page of the Event Viewer. To open the Event 
Viewer, go to Start -> Programs -> Administrative Tools -> Event Viewer. Look for an Error type 
and the source name should have “MassTransit” in it. Select the error and double click it. When 
the event opens, look at the description; the last few sentences of the description are frequently 
the most informative. 
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Configuring Remote Administration of MassTransit  
The file transfer engine runs as a service and can be accessed for viewing and administration by a 
separate application, the MassTransit Administrator. MassTransit Premier and Standard allow local and 
remote Administrators to connect if remote administration is enabled for both MySQL and the 
MassTransit Engine.  
 
The easiest way to configure remote administration for MySQL is to check the checkbox when you install 
MassTransit 6.1.1. If you already have MassTransit installed and want to enable Remote Administration, 
use the following instructions. Both MassTransit and MySQL will need to be configured before remote 
connections will be accepted. 
 
 

Configuring Remote Administration in MassTransit 
 

1. Via the MassTransit Administrator connect to the local server. 
2. Select the Setup button on the toolbar. 
3. Select the Special tab. 

 
4. Click the Set Remote Administrator Password… button. 
5. The Enter Password dialog appears; enter your password. This password will have to be entered 

by a Remote Administrator when it attempts to connect to your server. 
6. Select the OK button and now any Remote Administrators with the password can connect to your 

server. 
 
 

Configuring Remote Administration in MySQL 
NOTE: This is unnecessary if you selected the Enable remote login for this account checkbox during 
installation. 

 
1. Launch the MySQL Administrator. 
2. Select the User Administration page. 

a. Under User Accounts select the “masstransit” account. This account may have a different 
name depending on the username you entered on the “MySQL Settings” dialog during 
the installation of MassTransit. 
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b. While focus is on “masstransit” right click and select “Add host from which the user can 

connect”. 
c. The “Add Host” dialog appears; enter the name of the new host, and select OK to 

continue. Using “%” will allow any machine to connect to the database. For security 
purposes, it is better to specify a specific host IP if only a limited number of hosts will 
need to perform remote administration. 

 
d. The new host populates below the masstransit account. 
e. The password on the General tab auto-populates the MySQLpassword used when you 

installed MassTransit. Remote administrators will not need to know this password to 
connect. 
 
NOTE: Do NOT select the Apply Changes button until this host is completely 
configured. 
 

3. Verify the host you just created in the Users Accounts section is highlighted and select the 
Schema Privileges Tab. 

a. In the Schemas section, highlight mtdatabase. 
b. Go to the Available Privileges Section and highlight all of the items listed. 
c. Click the < button so all of the Available Privileges become Assigned Privileges. 
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NOTE: Do NOT select the Apply Changes button until this host is completely 
configured. 
 

4. Go to the Resources tab. 
a. Configure the values in the Limiting user resources section. The default is “0”; “Unlimited” 

is the default when the MassTransit installer creates this account. 
b. Select the Apply Changes button. 

 
NOTE: When you select the Apply Changes button, it looks like the host you just 
created has disappeared. It has not disappeared; it is just no longer visible from the 
MySQL Administrator. 

 
Now that you have configured both MySQL and MassTransit, Remote Administration is enabled. 
 
 

Troubleshooting 
Problem: A dialog appears stating, “An error occurred with MassTransit: Remote Administration is 
disabled because the required password has not been configured.” 
Solution:  Remote Administration is not enabled in MassTransit; follow Steps 1-6 to configure it. 
 
Problem: A dialog appears stating, “An error occurred with MassTransit: Failed to connect to server due 
to problems initializing – most likely a database issue.” 
Solution: Remote Administration is not enabled in MySQL; follow Steps 1-4 to configure it.  
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Web Configuration for Standard and Premier Servers 
For information about configuring MassTransit for use with web servers, see the Web Configuration 
Instructions document located on the MassTransit Latest Releases web page in the MassTransit 6.1.1 
Documentation section at http://support.grouplogic.com/mtlatest. 
 
 

Other MassTransit 6.1.1 Resources 
Go to http://support.grouplogic.com/mtlatest for additional articles to help you set up, configure, and use 
MassTransit 6.1.1 and its new features. The Group Logic Knowledge Base contains many articles that 
provide detailed information on MassTransit 6.1.1 and its features and components. 
 
 

Group Logic MassTransit Technical Support 
Please contact Group Logic Technical Support if you need assistance with installing MassTransit. Email 
support@grouplogic.com or call 703-527-7979. For a complete listing of the latest official release versions 
and documentation, go to http://support.grouplogic.com/mtlatest. 
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